Page 1 of 1

Stuck in firmware update

PostPosted: Mon Nov 07, 2016 8:53 pm
by vincentgall0n
Hello community!

I'm very pleased with the device and the feeling it provides - thank you for changing the game!

Today I decided to update the firmware to the current version and run into a problem.
I followed the instructions step by step for the macOS and still get stuck in the "Receiving..." - Part. The %-bar hits the 100% in the Coolterm-app but the devices won't restart itself. I followed those steps several times and on two different Mac OS X machines (one is on macSierra and one on El Capitan). I also changed the USB-Cable but still run into the same issues that the machine stucks (I left it for 20mins until I restart the steps). I also tried installing the drivers on one machine but no changes. Also the amount of the "lines" submitted is never the same but always stucks in the same area of 14xxx.

When I restart the Xenophone manually it says "no firmware".

Hope to find some help soon.

Re: Stuck in firmware update

PostPosted: Mon Nov 07, 2016 10:39 pm
by vincentgall0n
Well, no issues when updating the firmware on a Windows 8.1 system. Solved.

Re: Stuck in firmware update

PostPosted: Tue Mar 21, 2017 5:48 am
by Nelson_Baboon
(also sent support email)
Rather than create another topic, I figured I'd continue this one.

I failed miserably trying to update my new Xenophone to the latest firmware. I'm on a Mac 10.11.5, and (according to the docs) shouldn't need to install a driver. I have tried usb hubs and the Imac itself, with the same result each time. I cannot get coolterm to send the firmware file to the Xenophone (the software stops at 1%, and the display on the Xenophone just says that it's waiting for the firmware).

I provided more details in the email to support, but I'm puzzled as to what I could have possibly missed.

the forum doesn't seem very active yet. I"m hoping that someone else might have tried this with a mac and solved issues like this.

Re: Stuck in firmware update

PostPosted: Wed Mar 22, 2017 7:28 am
by Iman_JL
Please install the new driver from here:

http://www.ftdichip.com/ftdichip/Drivers/VCP.htm

1-Update only works on USB2 port (USB3 or USB3+HUB might not work properlly)
2-Try another USB cable
3-Try annother USB slot of your computer

if it still fails on mac, switch to a windows based PC.

Re: Stuck in firmware update

PostPosted: Thu Mar 23, 2017 7:21 pm
by Nelson_Baboon
Well, I got it to work, and it was entirely my fault. If I had noticed/remembered how I had my usb hooked up, I could have avoided all of this.

The basic idea was that I had my usb hub connected through another hub (that doesn't work for this) into the mac. Duh, but it was convenient when I set it up months ago, and it has worked for everything, except this obviously.

I made the direct connection and everything worked like a charm.

I wanted to post here because I didn't want people thinking that this didn't work on a mac. It worked beautifully. I wouldn't complain if the section starting with my post was deleted. these kind of posts can give people the wrong impression. Going to set up midi over usb, install the software editor, etc. Yay.

Re: Stuck in firmware update

PostPosted: Tue May 16, 2017 6:04 pm
by Sequentonal
Hi all, I just got this beaut of a synth and wanted to update the firmware.
I follow the instructions step by step but then i get stuck in CoolTerm... it doesn't see the .hex file...
any thoughts?
Edit: NVM.. i just dropped the hex file into coolterm and it started the transfer.

Re: Stuck in firmware update

PostPosted: Wed May 17, 2017 11:00 am
by Iman_JL
Run Coolterm > Connection > Send Text File ...

If you have purchased the synth recently, it must have the latest OS v2.1 pre-installed. and no need for updating.

Re: Stuck in firmware update

PostPosted: Tue May 23, 2017 2:12 am
by Sequentonal
Thanks :)
The problem was in coolterm, it doesn't have .hex files in the accepted file types list when clicking on send text file.
But as i said, dropping the file in the coolterm window initiated the transfer. :)